修车帮

修车帮

Posted by:
修车帮 QQ

修车帮官方帐号

1,915

奇怪的宝马X3 N52K发动机氧传感器故障

  • 2013-06-09
  • No Comment

故障描述:

一辆2010年产宝马X3越野车,行驶里程1万km,该车在1次涉水后造成发动机进水无法起动,由救援车拖到我厂进行维修。

故障分析:

接车后,发现空滤已经被水浸透,且已被撕裂损坏;拆下火花塞后,发现气缸内有很多积水,把水排净后,手动盘车发动机可以转动。之后,重点检查了各缸活塞能否到达上止点,发现各缸活塞均可以到达。又经过一些常规检查确定没有问题后,将发动机装复。此时起动发动机,发现只有1、3缸有400 kPa的缸压,其他缸均无缸压。拆下进气道,发现气门处有大量污物,导致气门被卡滞。彻底清洗进气道、缸筒后,重新测量缸压,发现各缸均可达到700kPa的缸压。再次起动发动机,发动机顺利起动,怠速运转平稳,但当踩下加速踏板将发动机转速提升至2500 r/min时,发动机振动较厉害。此时,再次测量各缸缸压,发现各缸缸压基本一致,都能达到约1.2 MPa。在征得用户同意后,笔者决定对发动机进行解体检查。

在分别对进排气凸轮轴、凸轮轴位置传感器及曲轴做好定位后,开始拆解发动机。解体发动机后,经仔细观察,发现2、4缸连杆变形,但它相对于发动机是纵向变形,因此从缸压上看不出问题。在更换1~6缸连杆后,装配好发动机(由于采用镁铝材质缸体,为避免电化学腐蚀,缸体外围螺栓采用铝制,每次拆卸必须更换),并用故障诊断仪GT1对电子气门执行了自适应操作。之后起动发动机,发动机顺利起动,各工况运转平稳,异常振动消失。

待发动机达到正常工作温度后,本以为故障已经排除,但却出现了“游车”现象。利用故障诊断仪对发动机控制系统进行检测,设备显示无故障码。继续观察数据流,空气流量计、冷却液温度传感器信号正常;1至3缸前氧传感器信号电压在2.0~2.5 V变化;4至6缸前氧传感器信号电压稳定在2.5 V,只有在往复踩踏加速踏板时电压值才会明显变化。在清除学习值后,“游车”现象消失,但发动机在运转2min后又出现“游车”现象。再次观察数据流,1至3缸前氧传感器信号电压又在2.0~2.5 V变化。从上述数据看,应该是混合气出现问题引发了“游车”,但导致宽带氧传感器电压变化过快的原因是出在发动机机械方面还是出在控制系统上呢?


图1分解后的镁铝发动机

 
图2配气正时调整机

鉴于该车搭载的是宝马最新的N52K镁铝发动机(图1),此款发动机采用了电子气门且进排气均装备了可变凸轮轴控制系统,且在装复发动机机械系统时没有采用正时专用工具(无此专用工具),笔者担心配气正时机构(图2)可能存在问题。于是找来正时专用工具,拆下链条张紧器,装入专用工具,其可以准确卡入凸轮轴、凸轮轴传感器及曲轴,因此可以确定配气正时机构安装正确。在确定配气正时机构没问题后,笔者认为暂时先不用考虑发动机控制系统的其他方面,因为该车既然涉过水,会不会是涉水时将氧传感器损坏了呢?为此,笔者决定将4、5、6缸的前氧传感器与1、2、3缸的前氧传感器互换,看故障症状是否会发生变化。在将氧传感器互换并清除学习值后重新起动发动机,没过多久发动机便开始游车。观察数据流,发现此时发生电压变化的氧传感器变为4、5、6缸。笔者决定尝试断开异常的氧传感器,因为当发动机控制单元识别到氧传感器被断开后将关闭氧传感器,并迫使发动机4、5、6缸处于开环状态。经尝试,笔者发现发动机居然可以正常运转很长时间。至此,可以确定1、2、3缸前氧传感器损坏。

故障解决:

在更换1、2、3缸前氧传感器后,经过长时间试车,发动机工作正常,故障排除。

回顾总结:


图3新型宽频带氧传感器控制

对于该车的故障,笔者怎么也没有想到氧传感器损坏后会自己出现电压波动误导发动机控制单元调节混合气过浓,导致发动机游车。这是因为该车前氧传感器采用的新型宽频带氧传感器(图3),该类氧传感器不同于传统的二氧化锆式氧传感器,从4线变为6线,因为其内部增加了单元泵。混合气浓时,λ电压值会升高,控制单元会升高单元泵的控制电流;混合气稀时,λ电压值会降低,控制降低单元泵的控制电流。当氧传传感器牌正常工作状态时,因突然进水熄火,当水进入氧传感器后,使在正常工作的较热状态的氧传感器突然变冷,瞬间破坏了其内部结构,从而导致传感器信号异常,引发了该车的故障。

发表评论

你必须登录才能发表评论。

back up ↑